Blog

[ do default stuff if no widgets ]

Flirc v0.91 Linux 64 bit released

I’ve updated the 64 bit linux binaries, although you can download the 32 bit deb file and install it just fine on a 64 bit OS.

The reason this would work is because I’ve temporarily given up on static linking. I don’t know why, but for some reason, the static compile of the QT GUI was horribly slow, and created artifacts on the screen. I eventually compiled the libraries again with a bunch more options enabled and got the application to run without the artifacts, but it was still extremely slow. I felt it was not acceptable in the standard of quality I want to set. So I bit the bullet and compiled dynamically adding all the necessary dependencies.

The font also doesn’t look funny in the GUI anymore, so overall, I may just leave it like this. I spent far too much time compiling the QT libraries, and I’ve got more important things to do.

Here is our list of goals:

1. Finish filing patent on proprietary algorithm powering flirc.

2. New version of GUI with more programming views

3. Update video with new GUI on home page.

4. Documentation and Help Section of the Site

5. Firmware wake from suspend support

6. Firmware repeat key detects

 

Leave a Reply